Python Issue ? D5 doesn't install and work when Verge3D is also installed (3DS Max 2021)

As per the title - I have 3DS Max 2021.

I also have some plug-ins, including Verge3D.

I installed your D5 to trial it and upon starting up 3DS Max, I was getting greeted everytime by an error message dialog box complaining about Verge3D.

So I contacted the authors of Verge3D, told them that this error has begun happening due to the install of D5 and they said “it is possible that this plugin clutters the environment variables somehow”, and they suggested I try changing the ADSK_3DSMAX_PYTHON_VERSION (in System Properties, via the “edit the system environment variables” search).

That version was set to 2 and it was suggested it should be 3, and to try that.

I changed that variable but now I have an error which they claim is a D5 error and to notify yourselves.

Here is the new error message I now get;

Yes. It may because Verge3D uses Python3 as its’ programming language, however, the D5 Converter for 3Ds Max uses Python2 as our programming language.

So I think if you amend the environment variables, it can only guarantee one program running normally. I recommend you to install 3Ds Max 2020 for both Verge3D and D5 Converter.

Right, I now have a problem.

I went to control panel and uninstalled D5 (that all uninstalled so fast I wasn’t convinced it deleted properly).

Nevertheless, I go into 3DS Max 2021 and the D5 Converter (on the Menu) is there and so I still get errors.

I tried deleting this D5 Converter from the Menu bar (via the Customise → Customise User Interface) and Saving that MaxStartUI.mnux file.

But if I try to Load that saved MaxStartUI.mnux file, 3DS Max crashes and the D5 Converter Menu Bar option remains…

And if I restart 3DS Max 2021 the D5 Convertor is still there in the Menu…


Thank you.

Sorry for the trouble, you can uninstall it with the following tool.

If you have any other problem, please feel free to contact us, thanks.

Thank you, that worked.

Please can you tell me - will D5 Render be eventually using Python 3 or will this problem always exist ?

I got exactly the same issue, but no luck with using the clean up tool. I could try the “remove shared assets” but dont really want to delete stuff that maybe used by other plugins. Please tell me how to manually uninstall the plugin.
Thanks in advance.

Got it. I had to manually delete the environment variable set by the plugin install.
Maybe you could consider to deliver the plugins with a real uninstaller, in order to properly uninstall it without any manual “hacks”